Date format is incorrect in 1Password for Mac

Options
12345679»

Comments

  • DmitriyP
    DmitriyP
    Community Member
    edited May 29
    Options

    Same, incredibly risky for passport information - so much risk exposure. It's incredible that this is so difficult to fix.
    Seems like it's finally fixed for me. I did cycle the regional settings to something else and then back, idk if related.

  • sema
    sema
    Community Member
    Options

    For me the issue got fixed when I switched my system language to "English (UK)". Now the date format in 1Password matches what I select in system settings.

  • Tirioka
    Tirioka
    Community Member
    Options

    The date format on 1Password for MacOS version 8.10.33 is also not correct for entries like Passport details, which is very annoying, since this is probably one of the more important entries when making flight bookings for example. Date and time formats should ALWAYS follow OS settings, wich I have set to dd/mm/yyyy and 24 hour. Would be great if this could be fixed asap. - only issue I have encountered since paying for version 3 and now on a family subscription. Love the app otherwise!

  • FairyFloss
    FairyFloss
    Community Member
    Options

    Hey Team!
    I see that there is ongoing work on date formatting, and wanted to add some behaviour that I am experiencing - couldn't find similar on the thread.
    release: 1Password for Mac 8.10.33
    platform: macOS Sonoma 14.5
    Settings on laptop:

    • region: Australia
    • preferred language: English (UK)

    Steps to recreate behaviour:

    • Create a new item type: Login.
    • Add a "date" attribute to the item.
    • The date defaults to current date in US format eg: 06/10/2024, and I have to update in US format.
    • Then save the item, and the date displays in correct format for Australia: 10/06/2024

    As others have mentioned - very confusing to the user when the day is 1-12 and cannot be distinguished from the month by value.
    The only indicator of the date format Is that when you add the new date attribute it defaults to current date. I would also prefer, in this case, where there is uncertainty of the date format being used, if it defaulted to MM/DD/YYYY - I think it is more obvious/standard/recognisable quickly, but also very unlikely that the date being entered will be set to the current date. I do however understand you'll be across a variety of use cases where this may be most appropriate.

  • xeal
    xeal
    Community Member
    edited 11:05AM
    Options

    It's mid-June 2024 and I can't believe this is still a not-fully-fixed issue after being reported two years ago. 😞 Is it really so hard to fix this properly?
    You certainly made some improvements as now I can finally see dates in 1Password using the format configured in macOS. Although the time is still shown using the 12-hour clock, while my macOS configuration is set to the 24-hour clock.

    I hope the screenshot below clearly shows the problem on macOS.

    • On the left side, it's a crop of the settings for date & time taken from my macOS "Language & Region" settings. Please note that I use ISO 8601 for both date and time.
    • On the right side, it's a crop of how 1Password formats a datetime. It mostly gets it right, except not using 24-hour format.

    Another problem is that when I edit a date field in 1Password, the field uses the US format (MM/DD/YYYY). Which is very strange (and confusing!) as my macOS language is set to English (Canada) and I have customized the format for dates in macOS to be ISO 8061 (YYYY-MM-DD). Did you guys just hardcode the US format for date fields? 😀

    When I look at the same password item, the date is shown using the ISO 8061 format, so respecting my OS settings. Good job on that as it was also shown in the US format before. 👍


    Forgot to mention above, but I'm on the latest versions of 1Password and macOS at the time of writing (2024-06-14).

  • Dave_1P
    Options

    @sema, @hsafer, @DmitriyP

    I’m happy that the date format is now correct in 1Password on your Macs.

    @fok

    I can confirm that your particular situation is not resolved by the fixes that have been released so far. Work continues to address a situation where the date format in 1Password is incorrect if your region does not match your preferred language.

    @bitkeeper and @VincentBounce

    The team is working on making sure that 1Password for Mac respects the system time/date format in all situations. There isn’t currently a plan to introduce a custom date/format that you can choose in 1Password itself but I’ve filed a feature request on your behalf to let the team know that you'd like to see this.

    @Tirioka and @xeal

    I’m sorry that you’re also running into the issue. Can you post a screenshot of your macOS region and language settings so that I can forward this to the team as well. You can find the settings here:

    1. Click on the  in the menu bar and then click System Settings.
    2. Click General.
    3. Click Language & Region.

    Take a screenshot of this window.

    @vishalsheth

    I'm sorry for the frustration, would you mind posting a screenshot of your current Language & Region settings screen from macOS so that I can confirm the status of your particular situation? You can use the same instructions that I posted directly above.

    @FairyFloss

    Thank you for the detailed issue report. I can confirm that your situation is something that I can reproduce on my end and I’ve passed this information along to the development team.

    -Dave

    ref: dev/core/core#8747
    ref: PB-40499376
    ref: PB-40499343

  • Tirioka
    Tirioka
    Community Member
    Options

    @Dave_1P thanks for the update above. As long as 1Password MacOS follows MacOS language and format settings I am good. I noticed it being “fixed”, but are also sure my time/date settings were as needed, but for whatever reason 1Password wasn’t showing them.

  • Dave_1P
    Options

    @Tirioka

    Thanks for the reply. Just to clarify, are you still running into the issue where the date format isn't correct for passport items on your Mac? If you are then could you take a screenshot of the following screen so that I can confirm whether you're running into a known issue:

    1. Click on the  in the menu bar and then click System Settings.
    2. Click General.
    3. Click Language & Region.

    -Dave