Safari Extension just counting

I uninstalled my old 1Password extension, then installed the new version (3.9.20). When I click on the 1Password icon and enter my 1Password password, it stays on the "lock" screen, says "connecting" and starts counting up from 1 to whatever (i let it get as high as 200 then killed it). Anybody know what's going on? I can switch over to Chrome and everything works great.

Comments

  • JasperJasper

    Team Member

    Hey @rhpage,

    The latest version of the browser extension is 4.0.1. You need to install that one to get your browser working with 1Password 4.

    You can download it here:

    Download 1Password 4 Browser Extensions

    Hope that helps! :)

  • had the same issue, fixed it for me. thanks :)

  • JasperJasper

    Team Member

    You're welcome, @AdieB. :D

  • Took a couple attempts, but it finally worked -- thank you! I uninstalled the old version 3, then clicked on the link you provided and attempted to installed the new version. It got hung up because it couldn't find the 1Password application. I checked the extensions again, and somehow it had reinstalled version 3. So I uninstalled that again, quit safari, and tried again. It still couldn't find the 1Password app, and had installed version 3 yet again. So I deleted it again, quit safari again, then opened the 1Password app, opened safari, downloaded the extension again, and this time it installed version 4. Something goofy's going on, but now that I have the right extension, I'm happy. Thanks!

  • sjksjk oversoul 1Password Alumni
    edited December 2013

    Hi, @rhpage and @AdieB.

    I'm glad you've got the 1P4 browser extension(s) up and running now with @JasperP's help. Here's something else you might like to check to make sure possible leftovers from 1P3 won't interfere …

    Open Activity Monitor from your Applications > Utilities folder and search for 1Password Agent. If it is still running, do the following:

    • Quit 1Password 4 if it's running.
    • Open Finder, select Go > Go to Folder…, and enter

      ~/Library/LaunchAgents

    • Delete the ws.agile.1PasswordAgent.plist file, if it exists.

    • Select Go > Go to Folder… again and enter

      ~/Library/Application Support/1Password

    • Delete the Agent folder, if it exists

    • Restart your Mac, then confirm with Activity Monitor that 1Password Agent is no longer running.
    • Open 1Password 4.
    • Select Help > Troubleshooting > Restart 1Password mini.

    That's all. :)

This discussion has been closed.